Builds the Klay Layered JavaScript Libraries

Build: #863 failed

Job: Compile and Package failed

Stages & jobs

  1. Build

  2. Deploy

Job result summary

Completed
Duration
5 minutes
Revision
b1b04229c40593ee5ec5c6ce77a4532edca87dcd b1b04229c40593ee5ec5c6ce77a4532edca87dcd
No failed test found. A possible compilation error occurred.

Error summary

The build generated some errors. See the full build log for more details.

Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0
Note: /var/atlassian/bamboo-data/xml-data/build-dir/KIPRAG-NKLG-JOB1/build/de.cau.cs.kieler.klayjs/src-external/de/cau/cs/kieler/klay/layered/intermediate/BigNodesLabelHandler.java uses unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.
Note: /var/atlassian/bamboo-data/xml-data/build-dir/KIPRAG-NKLG-JOB1/build/de.cau.cs.kieler.klayjs/src/de/cau/cs/kieler/klay/gwt/client/layout/RecursiveLGraphLayout.java uses or overrides a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: /var/atlassian/bamboo-data/xml-data/build-dir/KIPRAG-NKLG-JOB1/build/de.cau.cs.kieler.klayjs/src-external/de/cau/cs/kieler/klay/layered/intermediate/BigNodesLabelHandler.java uses unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.
Note: /var/atlassian/bamboo-data/xml-data/build-dir/KIPRAG-NKLG-JOB1/build/de.cau.cs.kieler.klayjs/src/de/cau/cs/kieler/klay/gwt/client/layout/RecursiveLGraphLayout.java uses or overrides a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: /var/atlassian/bamboo-data/xml-data/build-dir/KIPRAG-NKLG-JOB1/build/de.cau.cs.kieler.klayjs/src-external/de/cau/cs/kieler/klay/layered/intermediate/BigNodesLabelHandler.java uses unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.
Note: /var/atlassian/bamboo-data/xml-data/build-dir/KIPRAG-NKLG-JOB1/build/de.cau.cs.kieler.klayjs/src/de/cau/cs/kieler/klay/gwt/client/layout/RecursiveLGraphLayout.java uses or overrides a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: /var/atlassian/bamboo-data/xml-data/build-dir/KIPRAG-NKLG-JOB1/build/de.cau.cs.kieler.klayjs/src-external/de/cau/cs/kieler/klay/layered/intermediate/BigNodesLabelHandler.java uses unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.
Note: /var/atlassian/bamboo-data/xml-data/build-dir/KIPRAG-NKLG-JOB1/build/de.cau.cs.kieler.klayjs/src/de/cau/cs/kieler/klay/gwt/client/layout/RecursiveLGraphLayout.java uses or overrides a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: /var/atlassian/bamboo-data/xml-data/build-dir/KIPRAG-NKLG-JOB1/build/de.cau.cs.kieler.klayjs/src-external/de/cau/cs/kieler/klay/layered/intermediate/BigNodesLabelHandler.java uses unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.
npm WARN package.json klayJStest@0.0.0 No repository field.
npm WARN package.json klayJStest@0.0.0 license should be a valid SPDX license expression
npm WARN package.json klayJStest@0.0.0 No repository field.
npm WARN package.json klayJStest@0.0.0 license should be a valid SPDX license expression
Note: /var/atlassian/bamboo-data/xml-data/build-dir/KIPRAG-NKLG-JOB1/build/de.cau.cs.kieler.klayjs/src-external/de/cau/cs/kieler/klay/layered/intermediate/BigNodesLabelHandler.java uses unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':test/js:testBrowser'.
> Process 'command 'node'' finished with non-zero exit value 6

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.