Builds Keith based on the lasted ELK, KLighd, Pragmatics release and the semantics/keith master

Build: #2 was successful

Job: Build Theia Application Linux was successful

Stages & jobs

  1. Build Product

  2. Build Theia App

  3. Deploy Product

Job result summary

Completed
Duration
23 minutes
Agent
aeon-dockerized-agent2 (for benchmark)
Revisions
Semantics Theia
1120d4ded6e6795e5d12b7b0f211920f62ea02f9 1120d4ded6e6795e5d12b7b0f211920f62ea02f9
Keith
97cc445ccdb11731446de8021e65d68a192d4285 97cc445ccdb11731446de8021e65d68a192d4285

Error summary

The build generated some errors. See the full build log for more details.

gyp info it worked if it ends with ok
gyp info using node-gyp@5.1.0
gyp info using node@10.24.0 | linux | x64
gyp http GET https://nodejs.org/download/release/v10.24.0/node-v10.24.0-headers.tar.gz
gyp http 200 https://nodejs.org/download/release/v10.24.0/node-v10.24.0-headers.tar.gz
gyp http GET https://nodejs.org/download/release/v10.24.0/SHASUMS256.txt
gyp http 200 https://nodejs.org/download/release/v10.24.0/SHASUMS256.txt
gyp info ok
warning monaco-languageclient@0.13.0: The engine "vscode" appears to be invalid.
warning vscode-languageclient@6.1.3: The engine "vscode" appears to be invalid.
warning "@kieler/keith-diagram > @kieler/keith-language > @theia/messages > react-perfect-scrollbar@1.5.8" has unmet peer dependency "react@>=16.3.3".
warning "@kieler/keith-diagram > @kieler/keith-language > @theia/messages > react-perfect-scrollbar@1.5.8" has unmet peer dependency "react-dom@>=16.3.3".
warning "@kieler/keith-diagram > @kieler/keith-sprotty > sprotty > snabbdom-virtualize@0.7.0" has incorrect peer dependency "snabbdom@~0.6.6".
warning "@kieler/keith-diagram > @kieler/keith-language > @theia/monaco > onigasm > tslint@5.20.1" has unmet peer dependency "typescript@>=2.3.0-dev || >=2.4.0-dev || >=2.5.0-dev || >=2.6.0-dev || >=2.7.0-dev || >=2.8.0-dev || >=2.9.0-dev || >=3.0.0-dev || >= 3.1.0-dev || >= 3.2.0-dev".
warning "@kieler/keith-diagram > @kieler/keith-language > @theia/monaco > onigasm > tslint > tsutils@2.29.0" has unmet peer dependency "typescript@>=2.1.0 || >=2.1.0-dev || >=2.2.0-dev || >=2.3.0-dev || >=2.4.0-dev || >=2.5.0-dev || >=2.6.0-dev || >=2.7.0-dev || >=2.8.0-dev || >=2.9.0-dev || >= 3.0.0-dev || >= 3.1.0-dev".
warning "@theia/git > @theia/scm > react-autosize-textarea@7.1.0" has unmet peer dependency "react@^0.14.0 || ^15.0.0 || ^16.0.0".
warning "@theia/git > @theia/scm > react-autosize-textarea@7.1.0" has unmet peer dependency "react-dom@^0.14.0 || ^15.0.0 || ^16.0.0".
warning "@theia/cli > @theia/application-manager > font-awesome-webpack@0.0.5-beta.2" has unmet peer dependency "font-awesome@>=4.3.0".
warning "@theia/cli > @theia/application-manager > font-awesome-webpack > less-loader@2.2.3" has incorrect peer dependency "less@^2.3.1".
warning Workspaces can only be enabled in private projects.
lerna notice cli v3.22.1
lerna info versioning independent
lerna info ci enabled
lerna info Executing command in 10 packages: "yarn run prepare"
@kieler/keith-app-electron: Browserslist: caniuse-lite is outdated. Please run:
@kieler/keith-app-electron: npx browserslist@latest --update-db
@kieler/keith-app: Browserslist: caniuse-lite is outdated. Please run:
@kieler/keith-app: npx browserslist@latest --update-db
@kieler/keith-app-electron: (node:27479) DeprecationWarning: Tapable.apply is deprecated. Call apply on the plugin directly instead
@kieler/keith-app: (node:27468) DeprecationWarning: Tapable.apply is deprecated. Call apply on the plugin directly instead
lerna success run Ran npm script 'prepare' in 10 packages in 119.5s:
lerna success - @kieler/keith-app
lerna success - @kieler/keith-app-electron
lerna success - @kieler/keith-diagram
lerna success - @kieler/keith-diagram-options
lerna success - @kieler/keith-icons
lerna success - @kieler/keith-interactive
lerna success - @kieler/keith-kicool
lerna success - @kieler/keith-language
lerna success - @kieler/keith-simulation
lerna success - @kieler/keith-sprotty
--- downloading plugins ---
Browserslist: caniuse-lite is outdated. Please run:
npx browserslist@latest --update-db

(node:27550) DeprecationWarning: Tapable.apply is deprecated. Call apply on the plugin directly instead

(node:27620) DeprecationWarning: Tapable.apply is deprecated. Call apply on the plugin directly instead