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Overview

Mindstorms is a product family from Lego, with sensors, motors and a programmable brick. The newest iteration of the product family is the EV3 
programmable brick. Its predecessors are NXT and RCX. In the following we will see how to develop applications for the NXT brick.

Several open-source, third-party replacements for the offical Lego firmware have been developed. These support many well known programming 
languages, such as Java, C/C++, Python, Lua, etc. In the following we will use KIELER SCCharts to program Mindstorms running the Lego Java Operating 
System ( ). Therefore we will first install leJOS NXJ and flash its firmware. Afterwards we will create a simple SCCharts project in KIELER that we will leJOS
compile and deploy to the NXT brick.

If you want to learn the SCCharts langugage first, you can follow these links:

Introduction to SCCharts
The Textual SCCharts Language SCT
SCCharts Examples

Download and install leJOS

Download and extract the newest archives for your Operating System from  (Linux/Mac) or use the Setup.exe (Windows).Sourceforce

The further installation is explained in detail at .http://www.lejos.org/nxt/nxj/tutorial/Preliminaries/GettingStarted.htm

Do not forget to flash the download leJOS firmware to the Mindstorms brick as explained in the tutorial!

Known issues

Linux

On Linux there is an issue when uploading the firmware because of a kernel module ( ). If you can't http://ubuntuforums.org/showthread.php?t=1123633
upload the firmware with your Linux OS, add  at the very end of the file . Afterwards blacklist cdc_acm /etc/modprobe.d/blacklist.conf
execute . This will remove the cdc_acm module from the kernel and prevent its restart. Now try to flash the firmware again.sudo rmmod cdc_acm

Another issue is that the development package of  has to be installed. On Ubuntu you can do this by using .libusb sudo apt-get install libusb-dev

Furthermore, to use USB connection, a java library has to be compiled via . To do this perform  and start . If the ant build ant cd /path/to/leJOS/build ant
tool is not installed on your system, you can do so via .sudo apt-get install ant

Windows

The setup.exe of the current LEGO Fantom driver for Windows (1.2.0) has an awkward issue. If you get an error message (Developer Error) because an .
msi file could not be found, don't panic. The file is part of the downladed archive (in the Products folder) but you have to start it manually.

Mac OS X

http://www.lejos.org/
https://rtsys.informatik.uni-kiel.de/confluence/pages/viewpage.action?pageId=6750218
https://rtsys.informatik.uni-kiel.de/confluence/display/KIELER/Textual+SCCharts+Language+SCT
https://rtsys.informatik.uni-kiel.de/confluence/display/KIELER/Examples
http://sourceforge.net/projects/nxt.lejos.p/files/
http://www.lejos.org/nxt/nxj/tutorial/Preliminaries/GettingStarted.htm
http://ubuntuforums.org/showthread.php?t=1123633


1.  

2.  
a.  
b.  

The  tools require a  version of Java. However, newer 32 Bit versions of Java are not longer available for Mac. Thus to use leJOS the leJOS NXJ 32 Bit
installation of , which is the last one that supports a 32 Bit mode. You can download the installer for Java 1.6 from Java 1.6 is required https://support.

. It will install Java 1.6 to  so that the apple.com/kb/dl1572?locale=en_US /System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home
environment variable , which is set in the installation instructions, points to the correct path.LEJOS_NXT_JAVA_HOME

The environment variable LEJOS_NXT_JAVA_HOME is set in the installation tutorial by editing ~/.profile. However, on a Mac the environment variables 
defined in this file are not visible for GUI Applications, only for apps started from terminal. Thus to use leJOS together with KIELER, one either has to start 
KIELER from terminal or set the environment variable so that all GUI applications can access it. However, this does not seem to be trivial on Mac (see also 

).http://stackoverflow.com/questions/135688/setting-environment-variables-in-os-x

Test the Mindstorm

A simple Hello World application for the Mindstorms is developed as part of the leJOS tutorial http://www.lejos.org/nxt/nxj/tutorial/Preliminaries
/FirstProgram.htm

If this works with your device, you are able to start using KIELER to develop applications for the NXT brick.

Download and Configure KIELER

Download and unpack the nightly build  for your OS. It is available at the  page.of KIELER Downloads

 Java 1.8 is needed on all operating systems. With Java 1.7 not all plugins of KIELER will be loaded. , you will need to Note: Furthermore on Windows
download the  – even if you have a 64 bit operating system! Otherwise flashing the brick and uploading to the brick will fail.32 Bit version of KIELER

The Eclipse plugin for leJOS

There is an Eclipse plugin for leJOS which adds a project creation wizard and launch configuration to the platform.

You have to install it via the Eclipse Marketplace ( ). Help > Eclipse Marketplace...
OR
Install the plugin manually (Help > Install new Software...). Use the following update site 

for NXT: http://www.lejos.org/tools/eclipse/plugin/nxj/
for EV3: http://www.lejos.org/tools/eclipse/plugin/ev3/

If you have an  , install the  Plug-in. If you have an , install the  plugin.NXT brick leJOS NXJ EV3 brick leJOS EV3

Tip: To speed up the installation, uncheck the option "Contact all update sites during install to find required software". This will reduce the installation time 
from drastically (around 30 seconds instead 10 minutes).

After the installation, the plugin requires a . Go to  ( respectivellittle configuration Window > Preferences > leJOS NXJ Window > Preferences > leJOS EV3 
y) and enter the base directory of your   in the .leJOS installation NXJ_HOME field

For EV3, the plugin requires the IP address to connect to the brick (it may work without, but its safer to directly set the name. Reduces headache ). 
Check  and enter the  of the brick (displayed on the brick at startup).Connect to named brick IP adress

Creating an Example Project

https://support.apple.com/kb/dl1572?locale=en_US
https://support.apple.com/kb/dl1572?locale=en_US
http://stackoverflow.com/questions/135688/setting-environment-variables-in-os-x
http://www.lejos.org/nxt/nxj/tutorial/Preliminaries/FirstProgram.htm
http://www.lejos.org/nxt/nxj/tutorial/Preliminaries/FirstProgram.htm
https://rtsys.informatik.uni-kiel.de/confluence/display/KIELER/Downloads
http://www.lejos.org/tools/eclipse/plugin/nxj/
http://www.lejos.org/tools/eclipse/plugin/ev3/
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The following shows how to create a project, which will turn on a light if a button is pressed.

Create a new project:

Choose File > New > Project > KIELER SCCharts > SCCharts Project
In the project creation wizard that opens, select  or  (depending on your brick) as environment and hit Mindstorms NXJ  Mindstorms EV3 finish
The project wizard from the leJOS plugin opens. Set the project name to  and click .Flashlight finish
The project is created and the model file is opened in an editor (This might take a few seconds).

Edit the Model:

Change the contents of the model file to the following code and save it.

Floodlight.sct

scchart Flashlight {
    
    @Wrapper TouchSensor, S4
    input bool button;
    
    @Wrapper Floodlight, S1
    output bool light;
    
    initial state lightOff
    --> lightOn with button / light = true;
    
    state lightOn
    --> lightOff with !button / light = false;
}

This model will start in the state lightOff. If the button is pressed, it will turn on the light and change to the corresponding state, where the light is turned off, 
as soon as the button is not pressed anymore.

The annotations on the input and output variable are used to define which wrapper code is used to set / read them.  will set @Wrapper TouchSensor, S4
the input variable to true iff the touch sensor on the port S4 is pressed.  on the output variable will turn on the red led of the light @Wrapper Floodlight, S1
sensor that is attatched to port S1 iff the variable is true.

The available wrapper code snippets are defined in the directory  in ftl files (FreeMarker template files). The table below gives an overview assets/snippets
of the available wrapper code snippets.

Note: The Floodlight of the EV3 has a pretty high latency when switching between on and off.

Note: To view ftl files with highlighting, you may want to install the  feature from the JBoss Tools. However, this is not necessary to work FreeMarker IDE
with KIELER. JBoss Tools is available in the Eclipse Market Place and via update site. The update site for stable releases is http://download.jboss.org

. Note that only the  feature is required (Abridged JBoss Tools > FreeMarker IDE)./jbosstools/neon/stable/updates/ FreeMarker IDE

Build the Project:

The model is now ready to be compiled. Compilation is done in the background when the project is built. There are two ways to build a project: manually 
using , or automatically via . If the automatic build is enabled, resources are built when they are saved.Project > Build Project Project > Build Automatically

Building the project will create a new folder  in which all results are saved. This includes the compiled code from the model, an executable kieler-gen
simulation for the model and wrapper code that is ready to be deployed to the Mindstorms Brick.

The simulation is saved as JAR file in  and can be started via . Models and variables of a kieler-gen/sim/bin Right Click > Run as > KIELER Simulation
running simulation are displayed in the Data Pool View.

http://download.jboss.org/jbosstools/neon/stable/updates/
http://download.jboss.org/jbosstools/neon/stable/updates/


Besides the simulation, the finished wrapper code that can be uploaded to the Mindstorms brick is created as part of the project build. It is saved in kieler-
. To upload it to the Mindstorms brick, use .gen/model Right Click > Run as > leJOS NXT Program

Excluding the Simulation from the NXT Build

It is necessary to exclude the simulation directory and org.json directory inside kieler-gen from the NXT project specific build via Right Click > Build Path > 
. Afterwards the project has to be build again to remove all error markers in these directories.Exclude

Normally the NXT project attempts to compile all Java files in the kieler-gen directory for the platform. However, the simulation that is generated is not 
targeted at the Mindstorms brick and has compilation errors. It is compiled separately by KIELER.

Available Wrapper Code Snippets

There are several wrapper code snippets that can be used as annotations on input and output variables in the model file. These snippets are inserted in 
the main file template as part of the project build. The available snippets are listed below.

For sensors, the port has to be on of S1, S2, S3, S4.

For motors / actuators the port has to be one of A, B, C, D.

Snippet 
Name and 
Parameters

Description Use 
on

Variable 
type

Remark Defined 
in File

Clock, 
milliseconds

Sets a variable to true for one tick if the time in milliseconds passed since the 
last time it was set to true.

input bool See also ResetClock. timing.ftl

ResetClock, 
clockVariableN
ame, 
autoFalse

Resets a clock, such that the full time intervall of the clock has to elapse, 
before the clock will be set to true again.

If autoFalse is true, the reset variable will be set to false automatically.

output bool autoFalse is true per default. timing.ftl

Time Reads the elapsed time since program start (milliseconds) input int timing.ftl

TickLoopDura
tion, 
targetInMillisec
onds

Delays the execution until the tick loop takes at least as long as the given 
target duration.

The input variable is set to the actual tick loop duration.

input int Should be used on the very first 
input variable in the model, such 
that waiting is the last action in 
the tick loop.

In case the actual tick loop 
duration is longer than the target 
duration, the modeler can 
provide some error handling.

timing.ftl



TickWakeUp Sets the input variable to the current system time (milliseconds). The model 
can add to this variable to get a new value. This is the next system time the 
tick function will be called.

In other words, the next tick function call is delayed until the wake up time 
has been reached.

For instance the statement  could be used to call nextTickWakeUp += 500
the tick function again in 500 milliseconds, if nextTickWakeUp is an input with 
the corresponding annotation.

input int Should be used on the very last 
input variable in the model, such 
that waiting and settings the 
system time is the last action 
done, before the tick function 
call.

timing.ftl

TickCount Counts the ticks. First tick is 0, the following are 1, 2, 3, ... input int timing.ftl

Sleep Lets the current thread sleep the time in milliseconds of the variable value. output int timing.ftl

Print, 
autoReset

Prints a string variable if the string is not empty. If autoReset is true then the 
string variable is set to the empty string after it has been printed

output string autoReset is true per default. print.ftl

DrawString, 
x, y

Prints a string to the given x and y coordinate on the LCD. output string print.ftl

Button, button
Id

Sets a variable to true iff the button on the Mindstorms device is pressed. input bool The buttonId has to be one of 
ENTER, LEFT, RIGHT

touch_and_
buttons.ftl

TouchSensor,
port

Sets a variable to true iff the touch sensor on the given port is pressed. input bool touch_and_
buttons.ftl

LightSensor, 
port, 
percentValue

Reads  the value of a light sensor.

If percentValue is true, the a percent value is retured, based on the light 
sensor calibration.

input int percentValue is not available on 
EV3

light.ftl

CalibrateLight
Sensor, port, 
signal

Calibrates a light sensors high or low values. This means if the variable is 
true, the current value of the light sensor is taken as its reference high / low 
value.

output bool signal has to be one of High, Low light.ftl

Floodlight, 
port

Reads / Sets the state of the red lamp of the light sensor. input

output

bool light.ftl

RCXLamp, 
port

Turns an RCX lamp on (variable is true) or off (variable is false) output bool light.ftl

MotorSpeed, 
port, brake

Reads / Sets the speed of the motor in degrees per minute. If the speed 
value is negative, the motor will drive backwards. If the speed is zero, the 
motor will actively brake until it stops (brake is true) or remove all power and 
rollout (brake is false).

input

output

int brake is true per default. motor.ftl

MotorIsMovin
g, port

Sets a variable to true iff the motor on the given port is moving. input bool motor.ftl

MotorRotatio
n, port

Lets a motor rotate the variable value in degrees. This is only done if the 
value is unequal zero. If the value is negative, the motor rotates backwards. 
The variable is set to zero afterwards, such that setting the variable once to a 
value , will let the motor rotate  degrees.X X

output int motor.ftl

Beep, volume Plays a beep sound as long as the variable is true. output bool default volume is 10 sound.ftl

Buzz, volume Plays a buzz sound as long as the variable is true. output bool default volume is 10 sound.ftl

BeepSequenc
e, direction, 
volume

Plays a sequence of tones in either ascending or descending tone frequency 
if the variable is true.

The variable is set to false automatically.

output bool direction has to be one of Up, 
Down

default volume is 10

sound.ftl

UltrasonicSen
sor, port

Reads the distance that an ultrasonic sensor measures. input int ultrasonic.
ftl

Gyro, port, 
mode

Reads the value of a gyroscope. input int Not available on NXT

mode hat to be one of Angle, 
Rate

gyro.ftl

CalibrateGyro,
port, 
autoReset

Resets a gyroscope if the variable is true.

If autoReset is true, the variable is set to false automatically.

output bool autoReset is true per default gyro.ftl

Using the Remote Console (RConsole)

The display of the  is rather small compared to a Monitor. To ease debugging, one can print to a Remote Console (RConsole), if the USB cable NXT brick
is connected. This enables easier collection for example of sensor data.



To use the RConsole,  the  lines in the wrapper code template . Start the  tool in the bin directory of your uncomment RConsole Main.ftl nxjconsoleviewer l
. Now, when , the brick tries to connect with the nxjconsoleviewer.  button. If connected eJOS installation starting the application Press the Connect

succesfully, RConsole.println(...) commands will be written to this window.

The  has a similar feature. However it does not require any code changes. Just run the ev3console program in the bin directory of your leJOS EV3 brick
installation from command line. The output of the brick will be printed to this command line.

Problem Solving

The following presents typical issues and how to solve them.

Issue Typical Error 
Messages

Description Solution

leJOS EV3 does not 
support Java 8

"java.lang.
UnsupportedClassVer
sionError"

"unsupported major.
minor version"

You compile the sources in your project with 
Java 8 and upload them to the brick. However 
the lejos EV3 does not support Java 8

Go to the project properties and switch to Java 7 (Right Click on 
project > Properties > Java Compiler > Compiler compliance level)

Uploading to the 
brick does not 
respond

You compile a file successfully and when 
uploading the result, the connected brick is 
found. Anyway the upload does not terminate 
and does not react.

Flash the brick with the current leJOS firmware. If the brick is 
recognized correctly and the attempt to upload a compiled file fails 
then the firmware on the brick might be outdated.

Compilation and 
uploading works from 
command line but not 
when using KIELER

This Java instance 
does not support a 32-
bit JVM. Please install 
the desired version.

You can compile and upload code to the brick 
using the command line tools but when using 
KIELER an error message apprears because 
Java does not support 32-bit JVM.

Set the LEJOS_NXT_JAVA_HOME environment variable, such that 
it points to an 32-bit JDK and is visible for GUI applications (or at 
least KIELER). The process to do so differs on every OS. As 
alternative, execute KIELER from terminal.

Brick does nothing 
after program 
finished and prints 
"Program exit"

A program was uploaded and finished without 
errors. Afterwards the brick prints "Program exit" 
but does not open the main menu.

This is normal behaviour if uploading a program in debug mode 
instead run mode (  instead  in Eclipse). To get Debug As Run As
back to the main menu, press the ENTER and ESCAPE button of 
the brick at the same time.
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