KIML

Welcome to the second tutorial! We will work our way through installing a proper Eclipse setup and developing a first very basic layout algorithm. The
layout algorithm will integrate with KIML (KIELER Infrastructure for Meta-Layout), our very own framework that connects graphical editors with layout

algorithms. Once you're finished, you should be able to create new Eclipse plug-ins and know how to write layout algorithms for KIML. And you should
have a running Eclipse-based application that should look something like this:
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Preliminaries

There's a few things to do before we dive into the tutorial itself. For example, to do Eclipse programming, you will have to get your hands on an Eclipse
installation first. Read through the following sections to get ready for the tutorial tasks.

Required Software

For this tutorial, we need you to have Eclipse and Git installed:

1. Install Eclipse. For what we do, we recommend installing the Eclipse Modeling Tools, with a few extras. Our Wiki page on getting Eclipse has the
details: simply follow the instructions for downloading and installing Eclipse and you should be set.

2. You should already have obtained a working Git installation for the first tutorial.

General Remarks

Over the course of this tutorial, you will be writing a bit of code. Here's a few rules we ask you to follow:

® Allthe Java code you write as part of tutorials should be in packages with the prefix de. cau. cs. rt prak. | ogi n. tutori al N, where | ogi nis
your login name as used for your email address at the institute. This rule will apply to all tutorials — once we start with the actual practical projects,

we will choose more meaningful package name.

All Java classes, fields, and methods should be thoroughly documented with the standard Javadoc comment format. Javadoc comments are well

supported by Eclipse through code completion, syntax highlighting, and further features that help you. The code inside your methods should also
be well commented. Try to think about what kinds of information would help someone unfamiliar with your code understand it.
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During this tutorial, we will be using Git mostly from the command line instead of using Eclipse's built-in Git support. This is because we've found
Eclipse's Git support to be too unstable and buggy for us to trust it completely.

Finding Documentation


https://rtsys.informatik.uni-kiel.de/confluence/display/KIELER/Getting+Eclipse
http://download.oracle.com/javase/1.5.0/docs/tooldocs/windows/javadoc.html#javadoctags

During the tutorial, we will cover each topic only briefly, so it is always a good idea to find more information online. Here's some more resources that will
prove helpful:

® Java Platform, Standard Edition 6 API Specification
As Java programmers, you will already know this one, but it's so important and helpful that it's worth repeating. The API documentation contains
just about everything you need to know about the API provided by Java6.
® Eclipse Help System
Eclipse comes with its own help system that contains a wealth of information. You will be spending most of your time in the Platform Plug-in
Developer Guide, which contains the following three important sections:
® Programmer's Guide
When you encounter a new topic, such as SWT or JFace, the Programmer's Guide often contains helpful articles to give you a first
overview. Recommended reading.
® References -> API Reference
One of the two most important parts of the Eclipse Help System, the API Reference contains the Javadoc documentation of all Eclipse
framework classes. Extremely helpful.
® References -> Extension Points Reference
The other of the two most important parts of the Eclipse Help System, the Extension Point Reference lists all extension points of the
Eclipse framework along with information about what they are and how to use them. Also extremely helpful.
® Eclipsepedia
The official Eclipse Wiki. Contains a wealth of information on Eclipse programming.
® Eclipse Resources
Provides forums, tutorials, articles, presentations, etc. on Eclipse and Eclipse-related topics.

You will find that despite of all of these resources Eclipse is still not as well commented and documented as we'd like it to be. Finding out how stuff works
in the world of Eclipse can thus sometimes be a challenge. However, this does not only apply to you, but also to many people who are conveniently
connected by something called The Internet. It should go without saying that if all else fails, Google often turns up great tutorials or solutions to problems
you may run into. And if it doesn't, Miro and | will be happy to help you as well.

As far as KIML and layout algorithms are concerned, you can always refer to our Wiki which has a section about KIML and the KIELER layout projects.
The documentation is not complete, however, so feel free to ask Miro or Christoph Daniel for help if you have questions that the documentation fails to
answer.

Preparing the Repository

We have created a Git repository for everyone to do his tutorials in. You can access the repository online through our Stash tool over here. Clone that
repository:

1. Open a console window and navigate to an empty directory that the repository should be placed in.

2. Enter the command git clone ssh://git@it.rtsys.informatik.uni-kiel.de:7999/PRAK/ 13ss-|ayout-tutorials.git

including the final dot, which tells git to clone the repository into the current directory instead of a subdirectory)
3. You should now have a clone of the repository in the current directory.

You will use this repository for all your tutorial work, along with everyone else. To make sure that you don't interfere with each other, everyone will work on
a different branch. This is not exactly how people usually use Git, but goes to demonstrate Git's flexibility... Add a branch for you to work in:

1. Enter git checkout -b |ogin_nane

You have just added and checked out a new branch. Everything you commit will go to this branch. To push your local commits to the server (which you will
need to do so we can access your results), do the following:

1. Enter git push origin |ogin_nane
You would usually have to enter gi t pul | first, but since nobody will mess with your branch anyway this won't be necessary. By the way, you only need

to mention ori gi n | ogi n_nane with the firstgi t push, since Git doesn't know where to push the branch yet. After the first time, Git remembers the
information and it will be enough to just enter gi t push.

Finding the KIML Sources

If you want to develop a layout algorithm using KIML, you will have to get your hands at the KIML source code first. Of course, the code is available
through a Git repository.

1. Open a console window and navigate to an empty directory that the repository should be placed in.
2. Enter the command git clone ssh://git@it.rtsys.informatik.uni-kiel.de:7999/KI ELER/ pragnatics. git
3. You should now have a clone of the repository in the current directory.

KIML is implemented as an Eclipse plug-in that you will have to import into your Eclipse workspace. We won't do this now; it will be one of the first steps in
the development of your layout algorithm.

Developing Your First Layout Algorithm

Now that the preliminaries are out of the way, it's time to develop your first layout algorithm! It will, however, be a very simple one. This tutorial focuses on
creating Eclipse plug-ins and on learning how to develop with KIML; thinking of and implementing cool layout algorithms is what the rest of the practical will
focus on, and that is where the fun will be had!

(


http://download.oracle.com/javase/6/docs/api/
http://help.eclipse.org/juno/index.jsp
http://wiki.eclipse.org/Main_Page
http://www.eclipse.org/resources/
http://www.google.de
https://rtsys.informatik.uni-kiel.de/confluence/pages/viewpage.action?pageId=328059
http://git.rtsys.informatik.uni-kiel.de:7990/projects/PRAK/repos/12ws-eclipse-tutorials/browse
ssh://git@git.rtsys.informatik.uni-kiel.de:7999/PRAK/13ss-layout-tutorials.git
ssh://git@git.rtsys.informatik.uni-kiel.de:7999/KIELER/pragmatics.git

1 Remember to replace each occurrence of | ogi n_name with your own login name (e.g. msp), and each occurrence of Logi n_nane with your
capitalized login name (e.g. Msp).

Setting Up Your Workspace
You will start by importing the plug-ins necessary to program with KIML.

1. Start Eclipse and create a new workspace.
2. Setup your workspace as explained in this guide.
3. We will now make the two local clones of our Git repositories known to Eclipse. To that end, open the Git Repository Exploring perspective
through Window -> Open Perspective -> Other.
. Click on Add an existing local Git repository and choose the location of the tutorial repository. Note that when you open the repository entry, the
branch you previously checked out is marked as the current branch under Branches -> Local.
. Add the KIML repository.
. We will now import the projects required for KIML development to your workspace. Right-click on the KIML repository and choose Import Projects.
. Choose Import existing projects, and select the plugins folder from the Working Directory. Then click Next.
. Import the following plug-ins. This consitutes a basic configuration for the development of layout algorithms.
de.cau.cs.kieler.core
de.cau.cs.kieler.core.kgraph
de.cau.cs.kieler.kiml
de.cau.cs.kieler.kiml.gmf
de.cau.cs.kieler.kiml.service
de.cau.cs.kieler.kiml.ui
® de.cau.cs.kieler.klay.layered

9. To actually test your layout algorithms, you will need some kind of simple graph editor. The following plug-ins will add our KEG editor to your

installation, which is just that.

® de.cau.cs.kieler.core.annotations

de.cau.cs.kieler.core.kgraph.edit
de.cau.cs.kieler.core.kivi
de.cau.cs.kieler.core.model
de.cau.cs.kieler.core.model.gmf
de.cau.cs.kieler.core.ui
de.cau.cs.kieler.karma
de.cau.cs.kieler.keg
de.cau.cs.kieler.keg.diagram
de.cau.cs.kieler.keg.diagram.custom
de.cau.cs.kieler.keg.edit
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Adding a New Plug-in
We need to create a new plug-in to implement the layout algorithm in. Switch back to the Java or Plug-in Development perspective and follow these steps:

1. Click File > New > Other... > Plug-in Development > Plug-in Project.

2. Enter de. cau. cs. rtprak. | ogi n_nane. tutorial 2 as the project name. Uncheck Use default location and use t ut ori al _reposi tory_pa
th/ de. cau. cs. rtprak. | ogi n_nane. tutori al 2 as the location. Click Next.

3. Setthe versionto 0. 1. 0. qual i fi er, vendorto Chri sti an- Al brechts-Uni versitéat zu Kiel, and execution environment to J2SE-1.5.
(do this for all plug-ins that you create!)

4. Uncheck all checkboxes in the Options group and click Finish.

5. If Eclipse asks you whether the Plug-in Development perspective should be opened, choose either Yes or No. It doesn't make much of a
difference anyway.

You should now commit your new, empty project to the Git repository. We will do that from within Eclipse.

1. Right-click your project in the Package Explorer and click Team > Share Project...

2. As the repository type, select Git and click Next.

3. Tell Eclipse what repository to add the project to. The repository you placed the project in is already preselected. Simply click Finish.
4. Since Git support is now enabled for the project, right-click it again and click Team > Commit...

5. Select all files, enter a (meaningful) commit message, and click Commit.

Writing the Layout Algorithm

When writing our layout algorithm, we are going to need to be able to access code defined in several other plug-ins. To do that, we need to add
dependencies to those plug-ins:

1. In your new plug-in, open the file META- | NF/ MANI FEST. MF. The plug-in manifest editor will open. Open its Dependencies tab.
2. Add dependencies to the following plug-ins:

® de.cau.cs.kieler.core

® de. cau.cs. kieler.core. kgraph

® de.cau.cs.kieler.kim
3. Save the editor.

Layout algorithms interface with KIML by means of a layout provider class that has to be created and registered with KIML.


https://rtsys.informatik.uni-kiel.de/confluence/display/KIELER/Configuring+Eclipse

1. Right-click the source folder of your plug-in and click New > Class.

2. Set the package to de. cau. cs. rtprak. | ogi n_nane. tutorial 2, enter Logi n_nameLayout Provi der as the class name, and select de.
cau. cs. ki el er. kinl . Abstract Layout Provi der as the superclass. (This will only be available through the Browse dialog if you have
saved the plug-in manifest editor; if you haven't, Eclipse won't know about the new dependencies yet.)

3. Select Generate comments and click Finish.

Implement the layout provider class:

1. Add the following constants:

/** default value for spacing between nodes. */
private static final float DEFAULT_SPACI NG = 15. 0f;

2. Use the following code as the skeleton of the doLayout (. . .) method:

progr essMoni tor. begi n("Logi n_nane | ayouter", 1);
KShapeLayout parentLayout = parent Node. get Dat a( KShapelLayout . cl ass);

fl oat objectSpaci ng = parent Layout. get Property(Layout Opti ons. SPACI NG ;
if (objectSpacing < 0) {

obj ect Spaci ng = DEFAULT_SPACI NG,
}

fl oat borderSpaci ng = parent Layout. get Property(Layout Opti ons. BORDER_SPACI NG) ;
if (borderSpacing < 0) {

bor der Spaci ng = DEFAULT_SPACI NG
}

/] TODO Insert actual |ayout code.

progresshonitor. done();

3. Itis now time to write the code that places the nodes.Your code should place them next to each other in a row, as seen in the screenshot at the
beginning of the tutorial.

@ Tips
The following tips might come in handy...

® Read the documentation of the KGraph and KLayoutData meta models. The input to the layout algorithm is a KNode that has child KNo
des for every node in the graph. Iterate over these nodes by iterating over the get Chi | dr en() list of the par ent Node argument.
® Retrieve the size of a node and set its position later using the following code:

KShapeLayout nodelLayout = node. get Dat a( KShapelLayout . cl ass);

/'l Retrieving the size
float wi dth = nodeLayout.getWdth();
float hei ght = nodeLayout. get Hei ght();

/1 Setting the position
nodelLayout . set Xpos(x) ;
nodelLayout . set Ypos(y);

® obj ect Spaci ng is the spacing to be left between each pair of nodes.

® border Spaci ng is the spacing to be left to the borders of the drawing. The top left node's coordinates must therefore be at least ( bor
der Spaci ng, border Spaci ng) .

® At the end of the method, set the width and height of par ent Layout such that it is large enough to hold the whole drawing, including
borders.

* A complete layout algorithm will of course also route the edges between the nodes. Ignore that for now — you will do this at a later step.

Before you can test your layout code, you will have to register your new layout provider with KIML.

. Open the META- | NF/ MANI FEST. MF file again and switch to the Extensions tab.

. Add an extension for de. cau. cs. ki el er. ki nl . | ayout. | ayout Provi ders.

. Right-click the extension and click New > layoutAlgorithm.

. Setthe name to Logi n_nanme Test Layouter and the class to your layout provider class name.

. Right-click the new layoutAlgorithm and click New > knownOption. Set option to de. cau. cs. ki el er. spaci ng.
. Add another knownOption for de. cau. cs. ki el er. bor der Spaci ng.
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https://rtsys.informatik.uni-kiel.de/confluence/display/KIELER/KGraph+Meta+Model
https://rtsys.informatik.uni-kiel.de/confluence/display/KIELER/KLayoutData+Meta+Model

7. Save the editor.

We will now have to add a new run configuration that will start an Eclipse instance with your layout code loaded into the application, ready to be used.

. Click Run > Debug Configurations...

. Right-click Eclipse Application and click New. Set the configuration's name to Layout Test .

In the Arguments tab, make sure the the program arguments include - debug and - consol eLog.

. On the Plug-ins tab, set Launch with to plug-ins selected below only. Click Deselect All, check the Workspace item in the tree, and click Add
Required Plug-ins.

. Click Apply to save your changes and then Debug to start an Eclipse instance to test with.

(4]

Test the layouter in your new Eclipse instance:

. Click New > Project... > General > Project and set the project name to something like Test .

Right-click the new project and click New > Empty KEG Graph. Enter a meaningful name and click Finish.

. Put a few nodes into the diagram. To properly test your code, you will want to vary the sizes of the nodes. It may also be a good idea to get into
the habit of giving each node a different name, such as N1, N2, etc. This will help you later if you have to debug your algorithm.

4. Open the Layout view through Window > Show View > Other... > KIELER Layout > Layout.

5. With your KEG diagram selected, set the Layout Algorithm option in the Layout view to your new algorithm.

6. Save your KEG diagram.

7. Trigger automatic layout by clicking the layout button in the toolbar, or by hitting Ctrl+R L (first Ctrl+R, then L).

@ T
You can see the direct output of your algorithm and the time it took to run it through the Layout Graph and Layout Time views. The views are

available through the de. cau. cs. ki el er. ki m . debug plug-in, which can be found in the plugins-dev folder of the KIML repository. You will
learn more about debugging layout algorithms in a layout tutorial or presentation.
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Once you're satisfied with your node placement code, it's time to take care of edge routing.

1. Add a new method that will implement the edge routing using the following skeleton code:

/*-k

* Routes the edges connecting the nodes in the given graph.

* @ar am parent Node the graph whose edges to route.

* @aramyStart y coordinate of the start of the edge routing area.

* @aram obj ect Spaci ng the object spacing.

* @eturn height used for edge routing.

*/

private float routeEdges(final KNode parentNode, final float yStart, final float objectSpacing) {
/] TODO | nplenent edge routing

return O;

2. Add acall to rout eEdges(...) inyourdoLayout (...) method and implement the latter.



@ Tips
Here's a few tips for implementing the edge routing:

® Each edge shall be drawn with three orthogonal line segments: one vertical segment below the start node, one vertical segment below
the target node, and a horizontal segment that connects the two.

® The horizontal segments of two different edges shall not have the same y-coordinate. Two neighboring horizontal segments shall be
placed at a distance of objectSpacing.

® See the screenshot at the top of the tutorial for an example.

® Find the edges in a graph by calling get Qut goi ngEdges() or get | ncom ngEdges() on the nodes.

® You can add bend points to edges through the edge's edge layout:

KEdgelLayout edgelLayout = edge. get Dat a( KEdgelLayout . cl ass);
KPoi nt bendPoi nt = KLayout Dat aFact ory. el NSTANCE. cr eat eKPoi nt () ;
edgelLayout . get BendPoi nt s() . add( bendPoi nt) ;

® You will want to clear the list of bend points of each edge layout before adding bend points to it. This will remove all bend points the
edge had prior to invoking your layout algorithm.

® Set the values of the points returned by get Sour cePoi nt () and get Tar get Poi nt () according to the positions where an edge
leaves its source node and reaches its target node.

® If you want, you can improve the edge routing code by allowing horizontal segments to share the same y-coordinate if that doesn't
make them overlap. Your goal could be to produce an edge routing that uses as little space as possible.

® |f that's not enough yet: can you find a way to find an order of the horizontal segments such that as few edge crossings as possible are
produced?

Once you're done implementing the edge routing code, test it by running your debug configuration again, as before.

Before You Run Away...

...don't forget to commit your layout algorithm to your repository, and to push your commits to the tutorial repository on our server. If it's not there, we won't
be able to see your work! ‘<
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